WebSite X5Help Center

 
Georgi K.
Georgi K.
User

A problem with elements in header and preview  en

Auteur : Georgi K.
Visité 529, Followers 1, Partagé 0  

I almost finished the example site I worked on. I will not comment on how many times the program crashes. It was very nervous and tiring.
Today, I decided to change one of the graphical elements in the header.
It was a rectangle I had transformed into a title with a mask and 2 effects.
Anyway. I delete this graphic file. That is when the last problem occurred. Although I deleted this header element, in the preview it still existed. I began to erase the elements of the header one after another. This did not fix the problem. Finally, the header was blank. But the preview shows something very different. Here are two screenshots that show the empty header and a preview of the empty header. On the screenshot of the preview, I noted the elements that should not be there. 
Can anyone help me deal with this problem because tomorrow evening I have to show this example site to my client.

Posté le
13 RéPONSES - 3 UTILE - 1 CORRECT
Andre E
Andre E
Moderator

try ctrl buttun with the preview.

This loads all changes, it mighgt take a little longer to load the first time.

Hope this helps.....

Lire plus
Posté le de Andre E
Georgi K.
Georgi K.
User
Auteur

Oh, this was the first one I tried.Unfortunately, it did not help.

Still thanks for the advice, of course!

Lire plus
Posté le de Georgi K.
Esahc ..
Esahc ..
Moderator

Georgi, is there any chance you have reduced the height of the header to zero in template structure?

Lire plus
Posté le de Esahc ..
Georgi K.
Georgi K.
User
Auteur

Esahc .., I will try, but why?

Lire plus
Posté le de Georgi K.
Esahc ..
Esahc ..
Moderator

I have built a few websites without a header by simply reducing the size to zero height, this causes anomalies if there is any content remaining which I forgot to remove first. It is not visible in the header in template content, but appears in preview.

Assuming you get these problems fixed, please make frequent use of step 5 export project and rename each one at the time. I am aware of very few people now experiencing stability issues with wx5, so if I had to put money on it I'd reckon either a hardware issue or a conflict with one drive, malware, antivirus, firewall, etc.

Lire plus
Posté le de Esahc ..
Georgi K.
Georgi K.
User
Auteur

Unfortunately, I can not remove a header because the person I'm doing this site wants the header to exist on every page on the site.

You may be right about the stability of this version of the program. On the other hand, I use different programs for graphic, video and audio editing, and I have no problems with their work. But I have written with several people in two forums that have been testing this program in recent months. All of them had very similar problems with instability. They did not use this program legally, so they do not write here on the official site. That's what I understood last week. And I had to do this first before I make a decision 1) buy this program and 2) make a site. Now I have no choice - I have to do this site. I do not have enough knowledge of html, php and javascript, so I have to use this program.

Anyway. I do not have time for more explanation. I'm grateful to anyone who can help!

Lire plus
Posté le de Georgi K.
Esahc ..
Esahc ..
Moderator

Georgi, if you export and create an iwzip of the project so far, is it less than 2gb? If so you can upload to WeTransfer.com , generate a link and I or one of us may be able to assist. If you do not want all and sundry playing with the project, select hidden in your first post and only Incomedia will see it.

Lire plus
Posté le de Esahc ..
Georgi K.
Georgi K.
User
Auteur

No, it is not a problem for me to share the project with everyone here (I hope it will be useful for others).The exported project got suspiciously small - about 12 MB.I do not know why.I uploaded it to wetransfer.com.Here's a link -

https://wetransfer.com/downloads/e5756b889a2730574dd26d86fde5a46020181212130041/2ff71797c26025a187d710859f4d34dc20181212130041/efb257

by the way, the same problem is not only in the header but also in the footer!

Lire plus
Posté le de Georgi K.
Esahc ..
Esahc ..
Moderator

Georgi, I have downloaded your project, but I cannot preview it. I suspect the same is true on your PC and what you see in your preview is the remains of the last successful generation of your site (I suspect if you delete the contents of the preview folder in your project you will get what I get.

I will continue to investigate (it is half past midnight here) but I may not get back to you until tomorrow. Congratulations, I have never seen this behaviour before :-)

For reasons I do not understand your project will not generate ANY pages.

Lire plus
Posté le de Esahc ..
Andre E
Andre E
Moderator

Georgi,

A very importand field for the functioning of the website is the webadres in step1 .

I changed this to: http://freecomunity.rf

and now it all works.

Please try this.

thx

Lire plus
Posté le de Andre E
Esahc ..
Esahc ..
Moderator

It is the question mark, if it is present anywhere in the url then preview files are not cleared and no new previews are generated or displayed.

The user does not know this is happening, there is no warning of any sort.

This should be fixed. Incomedia should not allow "illegal" characters in a URL (which seems fairly simple), an error message should appear (just as it does with a blank url) so the user knows not to proceed.

Lire plus
Posté le de Esahc ..