WebSite X5Help Center

 
Charlene G.
Charlene G.
User

Unable to import backup  en

Auteur : Charlene G.
Visité 459, Followers 1, Partagé 0  

My computer was stolen and today I am trying to get things installed on my new computer.

I am trying to restore a backup in Evo Version 12.  I am getting this error message when I try to import:

"An error occured while loading the project: (Object reference not set to an instance of an object)." 

The file type is "Website X5 Exported Project"

Can someone guide me as to what I am doing wrong? 

Posté le
24 RéPONSES - 1 CORRECT
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Charlene, if you have an iwzip file then simply open WX5 and select Import. Browse to the iwzip file and select it.

Have you actually managed to import the project but when you open it you get this message perhaps?

Or have you used some other form of backup (eg the Incomedia folder from your documents folder.)

Lire plus
Posté le de Esahc ..
Charlene G.
Charlene G.
User
Auteur

Here is a screen shot of what I am working with.  They should be iwzip files.  But I am receiving error messages when I try to import.  Here is the properties of one of the files I tried.

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

This is the dialog box when I double click to import the above file.  Sorry for multiple entries, but I cannot figure out how to attach more than one photo in an entry.

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

This is one of my files that contain "backup files."  I will note that since my computer was stolen, I had to redownload the WebX5 software and I entered my key and it seems to have installed okay.  But maybe there is a glitch in the downloaded program.

Lire plus
Posté le de Charlene G.
Wayne B.
Wayne B.
User

Hi Charlene,

Is the IWZIP backup stored on a USB External Drive or on a Network or Cloud based backup? X5 has some issues with OneDrive for example, as it does not always synchronise properly.

I suggest that you copy one of the IWZIP files on to your new computer's Hard Drive (make sure it is a full copy and not just a link to the file). You could make a new folder on your new machine and put it in there. Start X5 and navigate to the folder, then see if it opens. This might solve your issue and if not there are lots of other people who might be able to help further.

I do have a V12 license (although it's not installed on my computer currently) and there are others who have older versions installed, so we could try on our machines if yours still fails, then email youa new IWZIP if successful.

Regards

Wayne

Lire plus
Posté le de Wayne B.
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Charlene, your "backup of files.png" appears to be a full copy of your website (step 5, export website to disk) and as such cannot be opened by WX5 (although if you double click the index file you should see your website).

"dialogue box when I double cli.png" is the correct message to see, although I would open WX5, select import and then browse to the iwzip to import. You seem to already have projects in WX5, were these the result of successfully importing other projects after the theft?

"iwzip files.png" how did this iwzip file get created? Did you manually create it at step 5, export project? Normally WX5 names the iwzip file with the same name as the project. Did you perhaps rename each file on creation?

You can check the contents of an iwzip file (I suggest making a copy) by renaming as zip. Windows explorer should then open it. A glitch many years ago (perhaps you are affected?) meant that sometimes the iwzip could not be opened, the trick was to rename as zip, export to a folder and then use pkzip/7zip/etc to re-zip, then rename

https://helpcenter.websitex5.com/fr/post/243079

You appear to have comprehensive backups, is there any chance you ever backed up the complete working folder of your project? If you did you should be able to copy the folder to your default working folder (documents\incomedia\website X5 - Evolution?) and simply open the project.

Please let us know

PS to add screen shots to your post copy the page (ctrl C) or hit print screen and paste it to the post (CTRL V)

Lire plus
Posté le de Esahc ..
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

In spite of my ramblings in the previous post (sorry), there was a recent fix to WX5 (although I didnt think this issue affected V12).

Just in case. . .

If your old project used any optional objects, open WX5, open a new or existing project, go to step 3 and reinstall those optional objects. Now go back and try importing the project again.

Lire plus
Posté le de Esahc ..
Charlene G.
Charlene G.
User
Auteur

I have tried the following steps and thank you both for your help, but I still am having problems. The iwzip files were made directly from WebX5 to my hard drive through the export feature.  I also did backup of the files through the WebX5 program directly to my hard drive.  I have extensive backups (although not recent enough) but at least its something.  So I copied the exports to my new computer.  I was able to successfully load only one (from August 2020).  I don't understand why the ones created after August 2020 do not import.  I took a November 2021 iwzip file and renamed it as zip.  Then I extracted. Then I rezipped and renamed to iwzip.  I still get the same error messages.  When you ask "did I ever back up the complete working folder of my project" I think the answer is yes.  In addition to the Nov 2021 iwzip file, I have a file I called "November 2 2021" and in it are all the files.  Can that be loaded?  You also asked if I renamed the iwzip files after exporting them and yes, I did.  But I did that for the August 2020 iwzip and that imports okay.  I just really need to at least get the November 2021 to import.  Here are a couple of screen shots.

The first is the copy of the file that I believe backed up the project files.

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

This next screen shot is showing you the iwzip files.  The one that is titled "revised site with online shopping" is the only one that I can import.

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

Not sure if this is making a difference -- but I do not have any of the website files stored on my new hard drive.  For now, all i have are these backups.  Do I have to restore all my content somewhere on my new hard drive in order for the backups to import?  Thanks again for helping me with this!

Lire plus
Posté le de Charlene G.
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Charlene, I still believe that if this was the project file it would contain xml and iwprj files, the files I see in your first screendump appear to be the generated website.

With the iwzip files after 8/30/20 have you ensured all optional object used are already installed in WX5 (as referenced in my last post (snatching at straws sorry))

Backup 11_2_2021.iwzip will not import without fatal error? And yet you can rename and open in Windows explorer? Then export to folder, re-zip and rename as iwzip and when you import you get the same error?

PS If you have the bones of your project and the website is currently online, it may not be too onerous to copy and past content to bring it back up to date (although I have no idea how complex your website is when making that statement). Personally I would be taking this "opportunity" to purchase a current version and thrust your website into today's world.

Lire plus
Posté le de Esahc ..
Charlene G.
Charlene G.
User
Auteur

On the backup 11_2_2021 iwzip. I renamed, extracted, zipped and renamed again.  But I did not understand the part about opening in windows explorer. How do I do that? 

And about optional objects being installed -- I missed that part.  And I guess it is possible I installed objects on my old computer and have not installed them in this fresh software download.  How would I try to figure it out and install them?

Can I do anything with the backup file at all?   

Here is another screen shot of the backup file that I thought backed up the whole project.  I scrolled to the bottom and found an sitemap.xml file -- in case that was what you were looking for.  I did not open the admin and other file folders, but can if you think i should search for something.

Lire plus
Posté le de Charlene G.
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Charlene, if you had a copy/backup of your project folder, this is what it would look like. . . .

Unfortunately all you have is the website generated from the project.

If you unzipped the project into a folder and looked in that folder with Windows File Explorer it should look like this (extremely similar to the content of the project folder)

To check for missing optional objects, open a new or existing project, go to step 3 and click on manage.

Then select all categories and install anything that is marked ready to install (meaning you already own it)

After installing any optional objects available, then try again to import your project which throws the error (if it works I will be amazed but very pleased).

Can you provide a link to your website as it is currently online?

I have marked your post for Incomedia's attention in case I have missed the bleeding obvious (although they cannot actually help because your version is way too old). For what it's worth I believe they could help if you purchase the latest Evo version and need to import your V12 iwzip

Lire plus
Posté le de Esahc ..
Charlene G.
Charlene G.
User
Auteur

Thanks so much for all of these suggestions and I will be working on them this weekend.  

Our website is:  www.HiddenGardenArt.com

Let me know if you have any other thoughts after reviewing it and I will update you after I go through your suggestions.

Thank you!!

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

About installing optional objects: I have just started to work on this.  Most of the objects ask if I want to "preview" or "buy". But some have "update" listed instead of "buy".  So I went to update a couple and got this message.

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

And to continue from above -- about the "backup files."  I searched for "library.xml" and this is one of the file folders I found. While I was hoping to open the November backup, this may be the next closest.  But I don't know how to proceed with this option.  And of course I still want to make sure I get the objects that we think I need (above). Noting the error message that I was not connecting to the server -- could this be yet another issue?

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

More about backup files -- I just realized the one I found was Sept 2020 -- I thought it was 2021.  So I could use it if all else fails - but I really want to get the Nov 2021 opened.  Is there nothing I can do with file that you said was "Unfortunately all you have is the website generated from the project." ?  What purpose does this serve if I cannot use it?

Lire plus
Posté le de Charlene G.
Charlene G.
Charlene G.
User
Auteur

And to address your instructions on looking at the extracted folder in Windows Explorer -- this is the one I really want to get uploaded and I think it looks like your screen shot.  Let me know your thoughts on this too.  I can't tell you how much I appreciate your time and effort in guiding me through this process!!

Lire plus
Posté le de Charlene G.
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Charlene, the contents of the screen shot look as they should.

With the optional objects only install those that are ready to install or suggest update. You own these.

When complete, try import the original backup 11_2_2021.iwzip (not one you may have opened and recreated, you seem to have added an iwzip inside the iwzip?). If it fails I suggest you allow us to try and import it for you. You can contact me through https://www.esahc.com/

I can't promise you I will be successful, but I can promise to try. Wayne also offered to try for you in an earlier post. It would be better not to publish a link here to the file stored in wetransfer, your google docs, onedrive or elsewhere.

The purpose of the files generated as a website in a folder is so you can open your website locally with your choice of browser (sometimes the preview browser does not produce the same result as a real browser), just double click on index file. It is also used when you wish to upload your website using filezilla (or similar) rather than the built in FTP. Back in V12 I always exported the site to disk and then uploaded the contents of that folder to my host. At the time I knew no better :-)

Lire plus
Posté le de Esahc ..
Charlene G.
Charlene G.
User
Auteur

Hi. I still cannot install optional objects that ask for an update because of some kind of connection error.  Below is a screen shot of the error message.  I will contact you with the backupfile I am trying to work with as well.

Thanks.

Lire plus
Posté le de Charlene G.
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Awaiting iwzip. Hopefully it is less than 2gb :-)

Lire plus
Posté le de Esahc ..
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Charlene, your project was created with a later version of WX5, I have provided details via email.

Lire plus
Posté le de Esahc ..
Charlene G.
Charlene G.
User
Auteur

Thank you so much for figuring this out for me. I am a bit embarrassed that all of this was caused by my using old credentials, which led me to download an older version.  Now that I've logged in with current credentials, the correct version downloaded and I was able to open my project!  Thank you so much!!

Lire plus
Posté le de Charlene G.
Esahc ..
Esahc ..
Moderator
Meilleur utilisateur du mois EN

Better born lucky than rich!!

Enjoy!

Lire plus
Posté le de Esahc ..