WebSite X5Help Center

 
Vlado _.
Vlado _.
User

Version 16,17 problem with font  en

Author: Vlado _.
Visited 643, Followers 1, Shared 0  

Hi, I have a problem with font Papyrus which I added to version 16 (I updated to 17 today).

My logo is written in Papyrus, so I need this font in the websiteX5.

I added it successfully and everything looks great in the preview.

Problem is when I upload the webpages in the internet - all text in the papyrus is in other font as you can see at the attached photos.

In my previous version 9 everything worked fine.

Could you please tell me how can I solve it?

Thanks

v

Posted on the
9 ANSWERS - 1 USEFUL - 1 CORRECT
Esahc ..
Esahc ..
Moderator

Vlado

Papyrus will only be available to a user if they have the font installed on their device unless you embed the font in your site. This can be achieved by using Windows File Explorer, navigating to windows/fonts, finding Papyrus right click and select copy. Now navigate to a suitable directory on your PC outside of windows and paste the font there.

In WX5 open anything that lets you select a font and select "Other font types"

Click on add, select web font and browse to where you stored Papyrus, this should provide an interim solution.

Be aware that I am not sure of the legality of this proceedure (I believe Papyrus is copyright but can be purchased).

You should instead select a google font that meets your needs. These are free and will work on any device.

Read more
Posted on the from Esahc ..
Vlado _.
Vlado _.
User
Author

Hi Esahc,

Thanks for help, but as I wrote - I added Papyrus to websiteX5 successfully and everything looks great in the preview.

Font disappear when I upload web on the internet.

v

Read more
Posted on the from Vlado _.
Esahc ..
Esahc ..
Moderator

If you moved the font out of the windows directory before adding as above I would have thought it would work.

But as I said the only guaranteed way is to use a suitable Google font as a replacement. The alternative would be to place the logo with papyrus text as an image or purchase the font with all formats.

Read more
Posted on the from Esahc ..
Vlado _.
Vlado _.
User
Author

Hi, think I did it in the same way as what you advised and as I said, everything works perfectly in the preview.

Problem with the logo as an image is that I need it with transparent background.

What do you mean exactly "purchase the font with all formats."

I have no problem purchase font if will work properly - could you please sent me a link where and what exactly should I buy?

Thanks for help

v

Read more
Posted on the from Vlado _.
Esahc ..
Esahc ..
Moderator

Vlado, not everyone uses WIndows, and not every version of Windows included Papyrus :-(

Read more
Posted on the from Esahc ..
Vlado _.
Vlado _.
User
Author

So there is no chance have a web with payprus font?

v

Read more
Posted on the from Vlado _.
Esahc ..
Esahc ..
Moderator

yes there is - spend money :-(

or

Assemble your logo (use WX5 and remove background then preview), take a screen shot, paste it to a decent paint package, set background transparent and save as logo.png, you may prefer to save a number of sizes for various resolutions or needs.

Now put the logo where you need it.

Please be aware. this is not an issue in v16/v17 - it has always been an issue, you just were not aware of it (in early versions WX5 coverted text to images but did not tell you).

Read more
Posted on the from Esahc ..
Vlado _.
Vlado _.
User
Author

ok, I am gonna try it

thanks a lot

v

Read more
Posted on the from Vlado _.
Vlado _.
Vlado _.
User
Author

Hi Esahc,

thanks for help!

I made logo as an image in png with transparent background. It works with no problem.

Anyway I have another problem with background photos on smartphone.

I post it here  https://helpcenter.websitex5.com/en/post/202531

Would you please check it also this one for me?

Thank you in advance

v.

Read more
Posted on the from Vlado _.