WebSite X5Help Center

 
Nikolay Z.
Nikolay Z.
User

Added web fonts are not displayed  en

Author: Nikolay Z.
Visited 1964, Followers 2, Shared 0  

Added web-fonds do not display. For example, ath this site http://agroplan.ru font is displayed as Times New Roman though it must be Bebas Neue Bold. This font is added to the programm (see attached file).

Since last X5 update everything was OK.

Posted on the
47 ANSWERS
Marcos B.
Marcos B.
User

Same problem here, starts with the last Update 13.1.6.19

Read more
Posted on the from Marcos B.
A J.
A J.
User

Same issue here, is there any way to keep the web fonts I've added to the program and on my website from showing up as Times New Roman? Any help and answers on this issue would be much appreciated.

Regards

Read more
Posted on the from A J.
Esahc ..
Esahc ..
Moderator

N. Zhuravlev, Marcos and AJ

I have tested this on my sites and do not have an issue, but I use google fonts with the import code.

I assume you each use web fonts and embed individual fonts?

If you are using Webfont Essentials I know there is an issue with the latest version

https://helpcenter.websitex5.com/en/post/173801

although from the first post screen capture, this appears to not be the case.

It looks like you need Incomedia's help.

Read more
Posted on the from Esahc ..
A J.
A J.
User

Hello Esahc,

Would you be so kind as to point us in the correct direction to where we may find these import codes? Are they simply the fonts url? 

Regards,

Read more
Posted on the from A J.
Esahc ..
Esahc ..
Moderator

A J

If you are using Google Fonts, you will find the code as per screen capture once you have selected a font family

Read more
Posted on the from Esahc ..
A J.
A J.
User

Ok Thanks for the update Esahc. 

Regards,

Read more
Posted on the from A J.
Harizonda Noron
Harizonda Noron
User

as I naturally upgrade 13 1.6.19. fonts can not display appropriate eot files svg woff and ttf which is already set in the settings. After downgrade to previous versions all run perfectly

Read more
Posted on the from Harizonda Noron
A. Kris
A. Kris
User
Harizonda N.
as I naturally upgrade 13 1.6.19. fonts can not display appropriate eot files svg woff and ttf which is already set in the settings. After downgrade to previous versions all run perfectly

+1

Read more
Posted on the from A. Kris
Nikolay Z.
Nikolay Z.
User
Author
Harizonda N.
as I naturally upgrade 13 1.6.19. fonts can not display appropriate eot files svg woff and ttf which is already set in the settings. After downgrade to previous versions all run perfectly

Is there any instruction what to do to downgrade? 

Read more
Posted on the from Nikolay Z.
Harizonda Noron
Harizonda Noron
User
N. Zhuravlev
Harizonda N. as I naturally upgrade 13 1.6.19. fonts can not display appropriate eot files svg woff and ttf which is already set in the settings. After downgrade to previous versions all run perfectly Is there any instruction what to do to downgrade? 
every websitex5 issued a version update and I always back up the previous versions of software installers keep watch if there are still bug updates and there are some versions that I think are still a lot of bugs after the update then I go back to the previous version. one of its 13.1.6.19 versions is problematic with the font. all the font formats are set in the settings     

Read more
Posted on the from Harizonda Noron
Incomedia
Claudio D.
Incomedia

Hello Harizonda N.,

Does it happens only with this font or also with others?

Can you please open a private post where you send me this specific font so I can verify on what it depends?

Many thanks!

Read more
Posted on the from Claudio D.
Harizonda Noron
Harizonda Noron
User
Claudio D.
Hello Harizonda N., Does it happens only with this font or also with others? Can you please open a private post where you send me this specific font so I can verify on what it depends? Many thanks!
applies to all new fonts entered wink  . during a preview of all the fonts look normal fit the font already terseting but after send the project file to the hosting then it will display the base font. and now I am back to version 1.5.16 13 all back to normal

Read more
Posted on the from Harizonda Noron
Nikolay Z.
Nikolay Z.
User
Author
Claudio D.
Hello Harizonda N., Does it happens only with this font or also with others? Can you please open a private post where you send me this specific font so I can verify on what it depends? Many thanks!

Hi Claudio,

Can you help me to downgrade version untill your team solve the issue? 

Are there any instructions what to do?

Read more
Posted on the from Nikolay Z.
Harizonda Noron
Harizonda Noron
User
N. Zhuravlev
Claudio D. Hello Harizonda N., Does it happens only with this font or also with others? Can you please open a private post where you send me this specific font so I can verify on what it depends? Many thanks! Hi Claudio, Can you help me to downgrade version untill your team solve the issue?  Are there any instructions what to do?
to downgrade 13 1.5 16 https://helpcenter.websitex5.com/en/post/177175  It's just that the projects already carried out in 19 13.1.6 can not be open in the previous software. must be at least the same version during the project carried out

Read more
Posted on the from Harizonda Noron
Nikolay Z.
Nikolay Z.
User
Author
Harizonda N.
N. ZhuravlevClaudio D. Hello Harizonda N., Does it happens only with this font or also with others? Can you please open a private post where you send me this specific font so I can verify on what it depends? Many thanks! Hi Claudio, Can you help me to downgrade version untill your team solve the issue?  Are there any instructions what to do? to downgrade 13 1.5 16 https://helpcenter.websitex5.com/en/post/177175It's just that the projects already carried out in 19 13.1.6 can not be open in the previous software. must be at least the same version during the project carried out

Wrong advice. This version cannot open my projects because identifies them as "created by older version" 

2 Claudio: I am very glad that you are so calm. But here we lose money every day and a little worried that your tech support ignores both the problem and our request.

Read more
Posted on the from Nikolay Z.
Myron A.
Myron A.
User

I also recently updated to version 13.1.6.19 (X5 Professional).

Then I opened up a "backup" of my Lambert Paving website and then exported the site to a new folder.

Then I uploaded the entire folder to my FTP testing server.

The site came up fine, and all the Web fonts look absolutely fine, see: [ www.adita.com/lp/index.html ]

Just to make sure, I refreshed the browser windows [CTRL + F5] and checked again. All the Web fonts are good.

NOTE 1: All my fonts are .ttf (no eot files or svg woff).

NOTE 2: I did not use the Google fonts import codes.

Why is it that I am not having the problem that is being discussed in this thread?

Read more
Posted on the from Myron A.
Harizonda Noron
Harizonda Noron
User
Myron A.
I also recently updated to version 13.1.6.19 (X5 Professional). Then I opened up a "backup" of my Lambert Paving website and then exported the site to a new folder. Then I uploaded the entire folder to my FTP testing server. The site came up fine, and all the Web fonts look absolutely fine, see: [ www.adita.com/lp/index.html ] Just to make sure, I refreshed the browser windows [CTRL + F5] and checked again. All the Web fonts are good. NOTE 1: All my fonts are .ttf (no eot files or svg woff). NOTE 2: I did not use the Google fonts import codes. Why is it that I am not having the problem that is being discussed in this thread?
font ttf format only to view work offline. woff svg format is required to display custom fonts. it is the provisions of the software websitex5. if the website is opened on a device that has already installed its font will display it as it is installed but if it is opened on a device that does not installed the custom font the device will not be able to display that font 

Read more
Posted on the from Harizonda Noron
Myron A.
Myron A.
User

Your comment is incorrect.

I use .ttf Web Fonts that I download from Google Fonts and they all work fine.

To prove this, take a look at...

http:www.adita.com/ttf/index.html

The custom font you see here is called Pacifico, and it was downloaded from https://fonts.google.com

So you can definitely use .ttf fonts online, and they will display properly on PCs as well as Macs.

Read more
Posted on the from Myron A.
Incomedia
Claudio D.
Incomedia

Hello Harizonda N.,

It depends on the browser since some displays the truetype font format file and others the WOFF file.

Can you please send me one of the fonts you are experiencing the issue so I can make some tests to see on what it depends?

Many thanks!

Read more
Posted on the from Claudio D.
Myron A.
Myron A.
User

In my experience, the .ttf fonts work fine in Google Chrome, Microsoft Edge, Mozilla Firefox, Opera, Internet Explorer, and Safari.

Are there other browsers?

Read more
Posted on the from Myron A.
Harizonda Noron
Harizonda Noron
User
Claudio D.
Hello Harizonda N., It depends on the browser since some displays the truetype font format file and others the WOFF file. Can you please send me one of the fonts you are experiencing the issue so I can make some tests to see on what it depends? Many thanks!
all the fonts in the image I include below are not running when I use version 13.16 19 but if using previous versions all runs perfectly on all types of browsers. everytime i work on my project i always use 5 different devices to see the final look  Thank you in advance

Read more
Posted on the from Harizonda Noron
Harizonda Noron
Harizonda Noron
User
Harizonda N.
Claudio D. Hello Harizonda N., It depends on the browser since some displays the truetype font format file and others the WOFF file. Can you please send me one of the fonts you are experiencing the issue so I can make some tests to see on what it depends? Many thanks! all the fonts in the image I include below are not running when I use version 13.16 19 but if using previous versions all runs perfectly on all types of browsers. everytime i work on my project i always use 5 different devices to see the final look  Thank you in advance
Read more
Posted on the from Harizonda Noron
Myron A.
Myron A.
User

Hello Harizonda,

Your Comfortaa-Regular.ttf font works perfectly for me. Please take a look:

http://www.adita.com/ttf/index.html

In fact, I tried all the variations: Regular, BOLD, Italic, Bold Italic and they all look fine.

That actually surprised me because you only provided us with the "Regular" version of this font.

Read more
Posted on the from Myron A.
Harizonda Noron
Harizonda Noron
User
Myron A.
Hello Harizonda, Your Comfortaa-Regular.ttf font works perfectly for me. Please take a look: http://www.adita.com/ttf/index.html In fact, I tried all the variations: Regular, BOLD, Italic, Bold Italic and they all look fine. That actually surprised me because you only provided us with the "Regular" version of this font.
I have too many projects that I have produced and never get into trouble with fonts cool. a fter upgrading to version 13.1.6.19 font problems arise . I have tried to install webx5 on other pc and when uploaded experience the same thing.and when it was returned to the version 13 1.5 16 all went perfect. . in case of errors of procedure of dozens of projects that I've produced would have been problematic in previous versions cool

Read more
Posted on the from Harizonda Noron
Myron A.
Myron A.
User

Hello Harizonda,

Are you working with the English version of Website X5? I'm wondering if the language version of X5 matters, since I am having no problems with the English version.

Read more
Posted on the from Myron A.
Nikolay Z.
Nikolay Z.
User
Author

Added fonts still are not displayed, and support still does not support us.  

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

N. Zhuravlev, I tried to test your fonts (fabricshapes & Bebas Neue), but do not know where to get them, are they public domain? If you can tell us where we can download we can test for you in the latest update.

I know that Myron does not have an issue with webfonts (although I doubt he has your font/s either), and I only use google fonts and the import code, so you have me at a disadvantage I'm sorry (see https://helpcenter.websitex5.com/en/post/177378).

I know you have downgraded, but if you upgraded again, removed the webfonts and then inserted them again, is there a chance that this will fix the issue?

It appears that your post has been somewhat hijacked by other users with a similar issue, I am sure Claudio will be back to make further suggestions when his time permits.

Read more
Posted on the from Esahc ..
Myron A.
Myron A.
User
Esahc ..
I know that Myron does not have an issue with webfonts (although I doubt he has your font/s either), ...
  1. Well, l do have one of his fonts called Comfortaa-Regular.ttf that Harizonda sent in an earlier post (see above).
  2. You can see it displayed on my test page at http://www.adita.com/ttf/index.html
  3. Hopefully, Eshac's suggestions will help you.
Read more
Posted on the from Myron A.
Nikolay Z.
Nikolay Z.
User
Author
Esahc ..
N. Zhuravlev, I tried to test your fonts (fabricshapes & Bebas Neue), but do not know where to get them, are they public domain? If you can tell us where we can download we can test for you in the latest update. I know that Myron does not have an issue with webfonts (although I doubt he has your font/s either), and I only use google fonts and the import code, so you have me at a disadvantage I'm sorry (see https://helpcenter.websitex5.com/en/post/177378). I know you have downgraded, but if you upgraded again, removed the webfonts and then inserted them again, is there a chance that this will fix the issue? It appears that your post has been somewhat hijacked by other users with a similar issue, I am sure Claudio will be back to make further suggestions when his time permits.

You may take Bebas Neue from here: http://www.fontfabric.com/bebas-neue/

The link is at the bottom of page

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

Have you tried uninstalling and re-installing the webfonts?

Read more
Posted on the from Esahc ..
Harizonda Noron
Harizonda Noron
User

I've tried various ways. apparently for my font problem was not solved and was too tired to try it again. I've consulted claudio and have sent all the fonts I use. after claudio try he said no problem. so I decided let me stay on version 13 1.5 16 while waiting for webx5 14 in release. laughinglaughing

Read more
Posted on the from Harizonda Noron
Myron A.
Myron A.
User
Harizonda N.
I've consulted Claudio and have sent all the fonts I use. after Claudio try he said no problem.

Hello Harizonda,

I just downloaded the Bebas Neue font from the link that you provided.

There were .TTF versions and .OTF versions available.

I chose to install the .TTF versions. Please see...

http://www.adita.com/ttf/page-1.html

This page was created with the latest version of X5: v.13.1.6.19 and the font is perfect in all browsers EXCEPT Internet Explorer where only the Bebas Neue Bold font works properly. It is perfect in the Apple Safari browser as well.

How much do we really care about Internet Explorer, an obsolete browser?

Are you working with the English language version of Website X5?

Read more
Posted on the from Myron A.
Harizonda Noron
Harizonda Noron
User
Myron A.
Harizonda N. I've consulted Claudio and have sent all the fonts I use. after Claudio try he said no problem. Hello Harizonda, I just downloaded the Bebas Neue font from the link that you provided. There were .TTF versions and .OTF versions available. I chose to install the .TTF versions. Please see... http://www.adita.com/ttf/page-1.html This page was created with the latest version of X5: v.13.1.6.19 and the font is perfect in all browsers EXCEPT Internet Explorer where only the Bebas Neue Bold font works properly. It is perfect in the Apple Safari browser as well. How much do we really care about Internet Explorer, an obsolete browser? Are you working with the English language version of Website X5?
I have never used the  font bebas neue it is not mine. Don't be in my thought and n. Zhuravlev was the same person. I am from indonesia cool font that I use all I have given with claudio following picture of fact that happened in my computer with private posting .. I use english version of language and all my computer device use paid software to update default application like browser and driver .

Read more
Posted on the from Harizonda Noron
Myron A.
Myron A.
User

Hi Harizonda,

Whoops, you are correct. Sorry, I've answered to you when the actual post was from Zhuravlev. embarassed

Well, I hope your problems are resolved when Version 14 comes out.

Read more
Posted on the from Myron A.
Nikolay Z.
Nikolay Z.
User
Author
Esahc ..
Have you tried uninstalling and re-installing the webfonts?

Certainly, I did everything possible by myself before asking questions.

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

N. Zhuravlev, I do not know what to suggest.

If you intend to update to V14 I would wait because you will need to add all your fonts again at that time anyway

Normally I would suggest saving as iwzip (export the project) and then import the project to see if this clears the problem. In this case I am not hopeful because the fonts are embedded in the program, not the project. If we weren't so close to a new release of the project I would recommend a full install by downloading WX5 from your profile.

The only thing I know for sure is the problems do not happen with my V13.1.6.19

This image was taken from a PC without Bebas Neue font available after I uploaded a test site to my domain.

I did not use Bebas-Neue Bold, I only loaded the regular font and applied the bold attribute.

I am sorry I could not be more helpful.

Read more
Posted on the from Esahc ..
Nikolay Z.
Nikolay Z.
User
Author
Esahc ..
N. Zhuravlev, I do not know what to suggest. If you intend to update to V14 I would wait because you will need to add all your fonts again at that time anyway Normally I would suggest saving as iwzip (export the project) and then import the project to see if this clears the problem. In this case I am not hopeful because the fonts are embedded in the program, not the project. If we weren't so close to a new release of the project I would recommend a full install by downloading WX5 from your profile. The only thing I know for sure is the problems do not happen with my V13.1.6.19 This image was taken from a PC without Bebas Neue font available after I uploaded a test site to my domain. I did not use Bebas-Neue Bold, I only loaded the regular font and applied the bold attribute. I am sorry I could not be more helpful.

I uninstalled and re-installed fints again and:

1. At this page it helped, and BEBAS NEUE BOLD font appeared again http://www.masterplans.ru/index.html

2. And here - just Times New Romad (no matter what I did)  http://www.masterplans.ru/sostavlenie-biznes-plana.html

At both pages I used the same font - BEBAS NEUE BOLD.

Read more
Posted on the from Nikolay Z.
Esahc ..
Esahc ..
Moderator

Is this font issue visible on the local preview or only when published?

I assume you have used CTRL+preview to view the site locally?

If the preview is good, but the online version is not, have you forced the upload to replace every file or only those that have changed?

Read more
Posted on the from Esahc ..
Mike G.
Mike G.
User

This is a problem with webfonts where the line dissapears from the page.css files in the pcss folder that specifies the font, the only way to get it back is to re-edit every page and select the font again on a paragraph.

This is a big problem that needs fixing before V14 is out Iwould like my V13 fixed it was fine before the last update.

I don't want tohave to buy V14 to fix a problem with software I have bought.

See post:

https://helpcenter.websitex5.com/en/post/178598

Mike.

Read more
Posted on the from Mike G.
Incomedia
Claudio D.
Incomedia

Hello Mike,

the develoloper have been informed about this issue and they are verifying it.

Many thanks!

Read more
Posted on the from Claudio D.
Harizonda Noron
Harizonda Noron
User
Mike G.
This is a problem with webfonts where the line dissapears from the page.css files in the pcss folder that specifies the font, the only way to get it back is to re-edit every page and select the font again on a paragraph. This is a big problem that needs fixing before V14 is out Iwould like my V13 fixed it was fine before the last update. I don't want tohave to buy V14 to fix a problem with software I have bought. See post: https://helpcenter.websitex5.com/en/post/178598 Mike.
I a gree with you . because my problem with the font is not resolved with the latest x13 update and I have tried version 14 also did not solve the font problem. if  continue the project already created it seems like the font problem will continue to be a problem. unless  create a new project the font issue will appear according to the selected font

Read more
Posted on the from Harizonda Noron
Nikolay Z.
Nikolay Z.
User
Author

I can add following: after the problem appeared I deleted my font (BebasNeueBold) from the Preferences and reinstalled it. Then I select text, change the font to any other, then change again to my font - and all text with this font was restored on the whole page (unfortunately - not in the whole project, so I had to restore it page by page). 

Then I continue working, and this text and font are OK until WebsiteX5 work crashes next time - not a rare occasion. And after "Project files restored after crash" my font disappears one more time. And I have to repeat a restore cycle.

Read more
Posted on the from Nikolay Z.
Myron A.
Myron A.
User

With the new version, Website X5 PRO v.14, I am not having any problems with Web Fonts.

Note that I am only using Web Fonts that can be selected from v.14’s Google Font selection panel. This offers a wide variety of Web Fonts, and they work properly in all the Windows browsers as well as Apple’s Safari browser.

Read more
Posted on the from Myron A.
Incomedia
Claudio D.
Incomedia

Hello N. Zhuravlev,

The update has been released in the beta channel and can be installed after enrolling on http://beta.websitex5.com

Soon this update will be released as official updated.

Many thanks!

Read more
Posted on the from Claudio D.